/ Cisco

Cisco : Routage inter-VLANs

Je vous montre une procédure très simple montrant comment mettre en place du routage inter-VLANs sur un routeur de la marque Cisco.
SCHEMA

1 - Routeur

Mise en place du routage inter-VLANs sur un routeur et un commutateur de niveau 2.

  1. Affectation d'un nom au routeur
en
conf t
hostname ROUTEUR
  1. Activation de l'interface physique du côté LAN du routeur.
int fa0/1
	no sh
	exit
  1. Configuration des interfaces virtuelles VLAN
# Cas du VLAN n°30
int fa0/1.30
	ip address 192.168.30.254 255.255.255.0
	encapsulation dot1Q 30
	no sh
	exit

# Cas du VLAN n°60
int fa0/1.60
	ip address 192.168.60.254 255.255.255.0
	encapsulation dot1Q 60
	no sh
	exit
  1. Mise en place du serveur DHCP pour les deux VLANs
# Cas du VLAN n°30
ip dhcp pool VLAN30
	network 192.168.30.0 255.255.255.0
	default-router 192.168.30.254
	dns-server 192.168.30.254
	exit

# Cas du VLAN n°60
ip dhcp pool VLAN60
	network 192.168.60.0 255.255.255.0
	default-router 192.168.60.254
	dns-server 192.168.60.254
	exit
  1. Sauvegarde de la nouvelle configuration
exit
wr

1 - Switch

Maintenant faut configurer le commutateur de niveau 2.

  1. Affectation d'un nom au commutateur
en
conf t
hostname SWITCH
  1. Configuration de l'interface du lien entre le commutateur et le routeur.
int fa0/24
	no switchport mode trunk
	no switchport mode access
	switchport mode trunk
	switchport trunk allowed vlan 30,60
	no sh
	exit

Le mode "ACCESS" est un port qui est affecté qu'à un unique VLAN, alors que le mode "TRUNK" est un port qui est affecté à plusieurs VLANs, on l'utilise principalement dans le cadre de l'interconnexion entre deux équipements réseaux.

  1. Affectation des ports 1 à 12 au VLAN n°30 et de 13 à 24 au VLAN n°60.
int range fa0/1-12
	no switchport mode trunk
	no switchport mode access
	switchport mode access
	switchport access vlan 30
	no sh
	exit

int range fa0/13-24
	no switchport mode trunk
	no switchport mode access
	switchport mode access
	switchport access vlan 60
	no sh
	exit
  1. Sauvegarde de la nouvelle configuration
exit
wr

Ce n'est finalement pas du tout une procédure complexe non ?